Wiktionnaire:Questions techniques/décembre 2014

Définition, traduction, prononciation, anagramme et synonyme sur le dictionnaire libre Wiktionnaire.
Sauter à la navigation Sauter à la recherche

Page mensuelle des questions techniques posées en décembre 2014. Page précédente : novembre 2014Page suivante : janvier 2015Modifier ce cadre



Page de suivi des bugs dan Phabricator[modifier le wikicode]

Je viens de créer une tâche dans Phabricator (qui a remplacé bugzilla) qui permet de suivre les différentes tâches relatives au Wiktionnaire : https://phabricator.wikimedia.org/T76447.

Si vous avez un compte sur Phabricator, vous abonner à cette tâche permettra normalement de suivre l'évolution des sous-tâches. N'hésitez pas à ajouter vos bugs en sous-tâche pour faciliter son suivi (j'en ai peut-être oublié).

Ceci devrait avantageusement remplacer Wiktionnaire:Phabricator puisque le suivi sera automatique (sauf pour la description en français). — Dakdada 2 décembre 2014 à 10:22 (UTC)

Oui c'est mieux, la description figure déjà dans le consensus. JackPotte ($) 2 décembre 2014 à 12:34 (UTC)
Oui, mais pour que ce soit réellement efficace faudrait que les membres actifs du Wiktionnaire s’inscrivent sur Phabricator, quitte à effectuer un abonnement godillot de tous les bogues et améliorations en cours touchant de près ou de loin le Wiktionnaire. V!v£ l@ Rosière /Murmurer…/ 2 décembre 2014 à 12:57 (UTC)
J’aime pas m’inscrire. --GaAs 2 décembre 2014 à 21:06 (UTC)
Allez faut juste passer par MediaWiki et le tour est joué Hé hé !.
Le but n'est pas d'obliger les contributeurs à s'inscrire, mais surtout d'aider ceux qui sont intéressés à trouver facilement l'ensemble des bugs qui concernent le projet. — Dakdada 2 décembre 2014 à 21:33 (UTC)
Ouais enfin si il n’y a personne pour "faire pression" voilà ce qui arrive quand on réclame une amélioration qui ne concerne à priori que 2-3 peulés (en l’occurrence 12 de pas moins de 6 wiktionary différents). Une amélioration requise avant 2009, soit avant ma présence ici. Qui nous aurais épargné beaucoup de travail, de maintenance et aurais permis pas mal de corrections ; mais non… ils préfèrent développer un éditeur visuel bidon qu’à peine 1% des contributeurs utilisent et des bandeau jaunes fluos alarmistes pour faire cracher les dons. Tiens histoire de cracher encore un peu plus de bile : 1 jour à peine chrono en main pour la résolution d’un bug touchant à l’éditeur que personne n’utilise. V!v£ l@ Rosière /Murmurer…/ 2 décembre 2014 à 23:19 (UTC)
L'éditeur visuel avait un budget financier, présente-toi donc au comité qui alloue les fonds. Mon programme préféré sera la rapidité de chargement des pages. JackPotte ($) 2 décembre 2014 à 23:31 (UTC)
L’éditeur visuel n’est pas fait pour les projets Wiktionary en réalité, et c’est pour ça que nous avons eu à le demander sur accord communautaire. C’est sur les Wikipédias où il est activé par défaut (et d’ailleurs maintenant tous les projets quasiment sauf Wiktionary — car justement notre structure est mal adaptée à cet éditeur). En l’occurrence si le bug a été résolu si vite c’est évidemment parce que c’était extrêmement simple (revenir en arrière sur une simple coquille). Mais sur les projets où il est implémenté, genre Wikipédia, ça ne fait pas doute c’est un éditeur utile (avec près d’1 million de modifications effectuées avec). Si on le désactive ici ça devrait pas faire trop de mal, mais à priori un certain nombre de personnes n’auraient jamais pu apporter leur modifs sans cet éditeur, faute de connaitre la wikisyntaxe. — Automatik (discussion) 2 décembre 2014 à 23:33 (UTC)


J'ai également créé la tâche phab:T78531 pour suivre les bugs et demandes qui concernent le projet Wiktionary en général, ce qui permettra de mieux mutualiser les demandes globales (comme la gestion des liens interlangues par Wikidata). — Dakdada 15 décembre 2014 à 11:08 (UTC)

En lua, comment tester la présence d'un nbsp dans une chaine ?[modifier le wikicode]

Pour info, ça peut servir à tt le monde, alors je recopie ici ce que j’ai écrit sur w:WT:QT.

Eurêka !   n’est pas traduit (parsé) avant d’être passé au lua, donc si je teste la présence d’un espace insécable dans la chaine (sous la forme utf8 "\194\160" comme je l’ai fait, mais en fait de n’importe quelle façon), c’est normal que je ne le trouve pas, puisqu’il n’y en a pas. Il faut (aussi) tester la présence de la chaine " ".
--GaAs (discuter) 2 décembre 2014 à 20:05 (CET)

En complément, voir [1]. --GaAs 2 décembre 2014 à 21:02 (UTC)

Problème métaphysique avec Modèle:fr-accord-eau + Module:fr-flexion[modifier le wikicode]

Bonsoir. Pour fr-accord-eau, le code lua boite_eau_eaux_elle_elles() est censé reconnaitre automatiquement l’ancienne syntaxe

  • {{fr-accord-eau|radical|prononciation radical}}
  • {{fr-accord-eau|radical|prononciation radical|inv=partie invariable|pinv=prononciation partie invariable}}

de la nouvelle (qui doit donner le même résultat)

la détection étant faite en comparant le param 1 au radical détecté automatiquement (et en comptant sur le fait que la prononciation comporte des points de syllabation).

Le problème, c’est que ça ne fonctionne pas correctement pour les mots d’une syllabe comme beau, parce qu’alors radical égale prononciation radical (qui n’a évidemment pas de syllabation).

Les articles ne sont pas actuellement touchés, car utilisant tous l’ancienne syntaxe, mais la question se pose dans l’optique d’un futur passage de bot pour remplacer la syntaxe.

J’avoue ne pas avoir trouvé d’idée géniale pour arranger ça, alors je lance un brain-storming pour solliciter vos idées. Merci d’avance. --GaAs 10 décembre 2014 à 22:56 (UTC)

Si on fait un test comme if (Radic==args[1]) and (args[2] ~= nil), au lieu de if (Radic==args[1]), est-ce que ça ne résoudrait pas le problème ? Il faudrait bien sûr qu’aucune page n’utilisant l’ancienne syntaxe ne soit sous la forme {{fr-accord-eau|1}}, c’est-à-dire sans réserver de la place pour le second paramètre, même lorsque celui-ci est vide. — Automatik (discussion) 10 décembre 2014 à 23:09 (UTC)
Non, le paramètre de prononciation n’est pas forcément présent sur les pages existantes (jusqu’à preuve du contraire), et ça ne fonctionne pas avec {{fr-accord-eau|b|kɔm ɛ̃ ka.mjɔ̃}}. Voici ma liste de possibilités :
  1. Trouver un test général qui marche pour tous les modèles concernés (pistes : tester si le radical détecté automatiquement n’est composé que de consonnes, deviner alors automatiquement sa prononciation, en déduire ce que représente le param 1 ; c’est compliqué).
  2. Tester explicitement chaque cas particulier dans chaque fonction lua (il n’y en a pas bcp, mais on peut en oublier).
  3. Modifier manuellement les articles pour utiliser temporairement la syntaxe "de secours" {{fr-accord-eau|pron=b|pinv=kɔm ɛ̃ ka.mjɔ̃}} qui est déjà prise en charge (il n’y en a pas bcp, mais on peut en oublier).
  4. Ignorer le problème : passer un bot pour remplacer la syntaxe sur tous les articles utilisant une fonction lua donnée, et dès que c’est fait annuler le support de l’ancienne syntaxe dans la fonction lua (les articles concernés seront faux pdt le transitoire, mais redeviendront bon automatiquement).
Dans tous les cas sauf le dernier (4), un bot pourra mettre la syntaxe à jour en une seule fois pour l’ensemble des modèles, et sans urgence aucune. --GaAs 11 décembre 2014 à 10:15 (UTC)
Je n’ai trouvé qu'une page ne donnant qu'un paramètre : friponneau (cf. [2]), mais je l’ai enlevé, le féminin n’étant de toute façon pas attesté visiblement (et s’il l’était, il ne l’est pas assez par rapport au masculin). Sinon la solution 3 me parait la meilleure en attendant qu’un bot change tout. — Automatik (discussion) 11 décembre 2014 à 11:16 (UTC)

Bon, j’ai peut-être une bonne idée pour la solution 1. En français, la liste des groupes consonnantiques à problème (ie qui sont égaux à leur API), pouvant être racine d’un monosyllabe est je pense :

  • b, bl, d, f, (k), (kl), l, m, n, p, pl, ps, s, t, ts, v, w, z.
  • plus g, gl, s’il y a mauvaise utilisation de l’API (/g/ vs /ɡ/).
  • plus br, dr, fr, gr, (kr), pr, (sr), tr, vr, s’il y a mauvaise utilisation de l’API (/r/ vs /ʁ/).

Si je fais une fonction est_consonne_et_identique_api(ch) qui répond true si ch vaut l’une de ces chaines (en se limitant à la liste courte), alors le code suivant devrait fonctionner (Radic est le radical détecté automatiquement — ce qui fonctionne bien) :

    -- prononciation en param 1 ou 2 selon syntaxe ancienne/nouvelle
    if (not args[1]) or (args[1]=='') then
        --syntaxe nouvelle sans prononciation (c’était une erreur dans l’ancienne syntaxe de toute façon)
    elseif (Radic ~= args[1]) then
        --syntaxe nouvelle (le param 1 n’est pas le radical, donc c’est la prononciation, sinon c’est une erreur à corriger à la main)
        -- args[2] = ''prononciation partie invariable''
    elseif est_consonne_et_identique_api(args[1]) then
        if (not args[2]) then
            --syntaxe nouvelle avec la prononciation, ou syntaxe ancienne sans la prononciation
            --(mais en fait dans les deux cas la prononciation est égale à Radic)
        elseif (args[1] == args[2]) then
            --syntaxe ancienne (radical + prononciation qui sont identiques)
        else
            --syntaxe nouvelle (prononciation + prononciation partie invariable)
        end
    else
        --syntaxe ancienne 
    end

--GaAs 11 décembre 2014 à 18:39 (UTC)

Jobs soumis sur le Labs via 'cron'[modifier le wikicode]

Bonjour,

Y a-t-il un moyen de rediriger les mails reçus pour chaque job exécuté via la « cron » sur le Tool Labs ailleurs que sur notre boite mail perso (par exemple, dans un dossier perso sur le Labs) ? On reçoit en effet un mail par job exécuté via le cron, et ça fait beaucoup pour un job exécuté toutes les heures. Comment faites-vous pour éviter cette montagne de mails vous ? Merci — Automatik (discussion) 27 décembre 2014 à 18:01 (UTC)

Justement je me posais souvent cette question sans en avoir trouvé la réponse dans les préférences...
Poursuivons plutôt cette discussion dans ton paragraphe wikitech:Help_talk:Tool_Labs#Jobs_submitted_to_the_grid_via_.27cron.27. JackPotte ($) 27 décembre 2014 à 18:11 (UTC)
À priori la réponse doit se trouver là-dedans : wikitech:Help:Tool Labs#Email, mais ce n’est pas tout à fait clair pour moi… — Automatik (discussion) 27 décembre 2014 à 18:14 (UTC)
Ah oui, sur le moment j’avais tant envie de résoudre le problème que j’en oubliais mon message là-bas J’ai honte. Oui poursuivons là-bas. — Automatik (discussion) 27 décembre 2014 à 18:15 (UTC)

PROBLEME IMPORTANT ː je ne peux plus éditer le Wiktionnaire francophone[modifier le wikicode]

Je crois que c'est depuis hier que j'ai le problème, mais c'est seulement maintenant que je vois que ce problème est spécifique au Wiktionnaire francophone ː j'ai essayé sur un autre Wiktionnaire, et je n'ai pas de problème, et aussi sur Wikipédia, et je n'ai pas de problème.

Le problème ici est que, quand j'édite ou que je saisis dans la zone Rechercher, certains caractères sont mal rentrés ː voici ce que j'obtiens ː

astérisque ː ̈

deux-points ː ː (c'est bien un deux points, mais pas le normal)

double crochet ouvrant ː ʽ (un simple crochet ouvrant ou fermant marche)

double crochet fermant ː ʼ

simple accolade ouvrante ː ̪

double accolade ouvrante ː ̺

simple accolage fermante ː ̪

double accolade fermante ː ˌ

triple tilde ː ̴

Je précise que c'est apparu tout d'un coup, sans que j'aie touché à mes paramétrages.

Alors, qu'est-ce qui se passe ? Est-ce que d'autres ont aussi le problème ? Lmaltier

Tout en bas à gauche dans la barre, si tu cliques sur l'icône d'engrenage pour remettre en français ? JackPotte ($) 31 décembre 2014 à 18:48 (UTC)

Je ne connaissais pas cette commande. Mais j'ai regardé, et je suis bien en français... D'ailleurs, mon affichage est tout à fait habituel. Lmaltier

Si ces outils sont activés (par mégarde), tu dois voir par exemple que tu es en "SIL". Cela m'est déjà arrivé je suis sûr que ça vient de là. JackPotte ($) 31 décembre 2014 à 19:09 (UTC)

Effectivement : suite à ton conseil, j'ai essayé de sélectionner anglais, j'ai vu que le choix SIL était sélectionné, choix que j'ai changé en clavier local. Puis, je suis revenu en français. Maintenant, je ne vois plus ces choix (SIL et autres), même en anglais, mais le comportement est redevenu correct. Si ça nous est déjà arrivé à tous les deux, j'imagine que ça arrive aussi à beaucoup d'autres, et il faut être vraiment motivé pour essayer de régler le problème : la plus simple façon de le régler, c'est de ne plus contribuer ici. Peut-être que ça nous a fait perdre pas mal de contributeurs. Alors mes nouvelles questions :

  • comment ça a pu arriver ? Par inadvertance, d'accord, mais encore ?
  • qu'est-ce qu'on peut faire pour garantir que ça n'arrivera plus ? En tout cas, ça ne peut pas rester comme ça, ça mérite d'être signalé en tant que bug.

Lmaltier (discussion) 31 décembre 2014 à 19:40 (UTC)

Quand tu cliques dans le champ de recherche, la fenêtre d’édition, etc, il apparait en bas à droite sous la zone de saisie une petit clavier (probable que tu as cliqué dessus involontairement). Si tu cliques dessus, la dernière ligne est "désactiver les outils de saisie". Si tu cliques dessus, normalement il ne te le proposera plus, et donc il ne pourra plus y avoir de fausse manip involontaire.
Note que c’est un truc qui m’arrive aussi assez couramment avec l’option de langue de Windows, dont le raccourci clavier est ALT+SHIFT comme les touches de raccourci de MediaWiki. --GaAs 31 décembre 2014 à 20:13 (UTC)
Merci. je suis revenu ici parce que ça m'est encore arrivé (!), encore par inadvertance, et c'est bien d'avoir la réponse tout de suite. J'ai suivi ton conseil. Il n'empêche que du point de vue ergonomique, utilisabilité, c'est catastrophique. Il ne faut surtout pas essayer de faire aussi mal que Windows, à moins de vouloir faire fuir les contributeurs. Est-ce qu'on ne pourrait pas mettre cette désactivation par défaut, pour tout le monde ? Cela n'empêche pas de changer de langue par la suite, si on le désire. Mais le mieux serait de mettre cette préférence avec les autres, au lieu de compliquer au maximum l'interface couramment utilisée, ce qui réglerait le problème. C'est nouveau ? Lmaltier (discussion) 31 décembre 2014 à 20:31 (UTC)
Pas exactement nouveau, c’est un des résultats des travaux de la Fondation pour améliorer l’accessibilité aux langues indiennes (2 ans ?), et la présence de ce petit clavier est actuellement le standard sur les wikis de la Fondation.
Pour le supprimer je n’ai pas d’avis, mais il effectivement peu probable que des utilisateurs francophones occasionnels aient le réflexe de l’utiliser. --GaAs 31 décembre 2014 à 20:49 (UTC)
Donc, si je comprends bien, en Inde, beaucoup de contributeurs sont souvent amenés à changer de langue pour leur clavier ? Mais est-ce que ça ne pourrait pas être un choix de chaque projet de mettre ça par défaut ou pas, en fonction des besoins habituels de leurs contributeurs potentiels, tout en permettant à chaque utilisateur de changer ce comportement par défaut ? Et comment expliquer que je n'avais absolument jamais vu ce clavier, ni eu ce problème, et que je l'ai eu 2 fois en 3 jours ? Il y a encore des choses qui m'échappent et qui me font peur. Ou alors est-ce que ce n'était activé qu'en Vector, et que ça vient d'être généralisé à tout le monde ? Ce serait une explication. En tout cas, ça ne change rien au fait que ça a dû nous faire perdre des contributeurs. Lmaltier (discussion) 31 décembre 2014 à 21:57 (UTC)
Ta dernière explication est peut-être la bonne, il y a fort longtemps que je ne regarde plus Monobook. --GaAs 1 janvier 2015 à 11:19 (UTC)