Wiktionnaire:Questions techniques/novembre 2014

Définition, traduction, prononciation, anagramme et synonyme sur le dictionnaire libre Wiktionnaire.
Sauter à la navigation Sauter à la recherche

Page mensuelle des questions techniques posées en novembre 2014. Page précédente : octobre 2014Page suivante : décembre 2014Modifier ce cadre



PywikipediaBot[modifier le wikicode]

Déplacé depuis Wiktionnaire:Questions techniques/juillet 2013#PywikipediaBot


Bonjour, je rencontre un gros problème avec PywikipediaBot, j'ai installer python, j'ai téléchargé Pywikipedia, mais quand j'entre une commende (C:\pywikipedia>python generate_family_file.py) un message d'erreur apparait : "C:\pywikipedia n'est pas reconnu en tant que commande interne ou externe, un programme exécutable ou un fichier de commandes." Quelqu'un peut-il m'aider ?

Merci. — message non signé de 92.92.60.119 (d · c) du 1 novembre à 12:34 (UTC)

Windows n'ajoute pas automatiquement la commande "python" comme raccourci, il y a deux solutions :
  1. Ajouter Python.exe dans les variables d'environnement et rebooter.
  2. Le lancer avec le chemin absolu, ex : "C:\Program Files (x86)\Python\python.exe" "C:\pywikipedia\generate_family_file.py".
JackPotte ($) 1 novembre 2014 à 12:39 (UTC)

A noté que je compte utiliser ce bot sur Wikia, et non sur Wikipedia. "les variables d'environnement et rebooter" C'est où ça ? Merci d'avance !

Ce serait trop long pour moi à expliquer, il faudrait utiliser ton moteur de recherche un peu plus en profondeur avant de demander stp. JackPotte ($) 1 novembre 2014 à 12:57 (UTC)
J'ai utilisé l'autre solution et toujours le même problème, j'ai fais un screenshot, peut-être que ça t'aidera à trouver le problème : http://sournoishack.com/uploads/1296172493cmd.png

Merci de prendre de ton temps pour m'aider.

Bonjour, merci de mieux mettre en forme vos messages pour qu’ils soient agréables à la lecture svp.
Voici l’aide que je peux vous apporter : dans votre ligne de commande, vous avez tapé le chemin vers l’interpéteur python "python.exe". Ce n’est pas nécessaire sous Windows (par ailleurs, en présence d’espaces dans un chemin, il faut englober ce chemin de guillemets). Si vous exécutez un programme d’extension .py, Windows va automatiquement passer le programme à python.exe. Il suffit de vous placer dans le dossier contenant Pywikipedia puis de taper le jom du script à exécuter (uniquement le nom du script).
Le mieux, pour préparer l’avenir, est de créer un raccourci pour lancer plus rapidement Pywikipedia.
Pour cela, il vous faut suivre les étapes suivantes (fortement conseillé si vous souhaitez utiliser votre bot plusieurs fois) :
  • Allez dans l’explorateur Windows, puis retrouvez le dossier Pywikipedia que vous avez téléchargé.
  • Cliquez droit dessus
  • Faites "Créer un raccourci"
  • Cliquez droit sur le raccourci étant apparu dans le dossier. Cliquez "Propriétés"
  • Dans le champ "Cible", tapez cmd.exe.
  • Dans le champ "Démarrer dans", tapez le nom complet du chemin vers Pywikipedia (exemple : C:Users\Hector\Pywikipedia).
  • Si vous voulez utiliser un raccourci clavier, placez votre curseur dans le champ "Touche de raccourci". Donnez votre raccourci en le simulant sur votre clavier (par exemple, CTRL+ALT+W).
  • Faites OK. Votre raccourci est créé.
  • Placez ce raccourci sur votre bureau pour le retrouver plus facilement.
Il vous faut maintenant double-cliquer le raccourci pour lancer Pywikipedia.
Je vous ai décrit là les étapes de mw:Manual:Pywikibot/Installation#Windows_users:_create_a_shortcut. Pour tester que ça marche, double-cliquez votre raccourci, puis tapez version.py. Si vous voyez des informations sur Python et quelques variables du type use_api = True, alors c’est que Pywikibot marche pour vous Sourire. Sinon, dites ce que vous voyez.
Cordialement, — Automatik (discussion) 2 novembre 2014 à 16:13 (UTC)

Ça marche, merci énormément Automatik, tu es un génie ! Bonne continuation à toi, et je te souhaite une excellent soirée ! (Mes excuses pour la mise en forme, j’essayerais de faire de mon mieux la prochaine fois)

Euh, c'est normal qu'on me dit dise maintenant quand j'entre une commende commande ex: C:\Python27\python.exe generate_family_file.py ont on me dit : C:\Python27\python.exe n'est pas une application Win 32 valide." Vous pouvez me dire quel est le problème et comment le résoudre ? Merci.
Bonjour, à votre place j’aurais utilisé CCleaner (lien pour le télécharger). Pour ensuite le lancer et aller dans l’onglet « Registre », cliquer « Chercher les erreurs », puis après « corriger les erreurs sélectionnées ». Ensuite aller dans l’onglet « Nettoyeur » puis cliquer « nettoyer ». Puis redémarrer l’ordinateur (il faut souffrir pour résoudre des bugs). Ensuite, réessayer. Si ça ne marche pas, je vous conseille de vous rendre sur un forum d’entraide informatique comme CNET, puis d’ouvrir un nouveau sujet (la procédure sera plus longue que celle que je vous ai indiquée). — Automatik (discussion) 4 novembre 2014 à 18:17 (UTC)
D'accord, merci à toi.
C'est fait. Par contre, j'ai cliqué "corrigés les erreurs sélectionnés" j'ai donc pas été obligé de cliqué sur l'onglet nettoyeur puis de cliquer sur "nettoyé" est-ce normal ?
J’espère qu’il y est écrit « corriger les erreurs sélectionnées », parce que sinon il faut faire qqch pour corriger cette horreur. --GaAs 4 novembre 2014 à 19:30 (UTC)
Oui oui, il y avait marquer marqué ça, c'était juste une faute d'ortho de ma part...
Le logiciel n’oblige à rien. Mais je vous conseille tout de même de suivre la procédure indiquée jusqu’au bout. — Automatik (discussion) 4 novembre 2014 à 20:42 (UTC)

Portage wikicode --> lua (proposisiton d'aide)[modifier le wikicode]

Le portage des modèles de flexions vers Module:fr-flexion se passe assez bien, je n’ai pas actuellement de question à vous poser.

Ce message est donc surtout pour vous dire : si vous tentez le portage d’un modèle en module lua, je peux peux vous aider (je ne sais pas tout, mais j’ai appris plein de choses en le faisant, alors demandez-moi avant de perdre votre temps).

--GaAs 4 novembre 2014 à 21:18 (UTC)

Modèle:e (exposant) et classe CSS[modifier le wikicode]

Bonsoir. Il me semble que les réglages (taille, police, etc.) dans {{e}} devraient être gérés par Mediawiki:Common.css et non mis en en dur dans le modèle.

La façon actuelle de faire implique qu’une modification de {{e}} ne sera propagée à module:prononciation/p.h_aspire(frame), et ça c’est pas cool, àmha.

Vous en pensez quoi ? --GaAs 6 novembre 2014 à 19:37 (UTC)

OK pour créer une classe exposant à laquelle le Lua et le modèle pourront faire référence. Ainsi, plus de doublon sur le CSS à l'avenir. JackPotte ($) 6 novembre 2014 à 19:58 (UTC)
Il est toujours possible d'utiliser un modèle dans un module (frame:expandTemplate), mais c'est du bricolage et le CSS est le plus adapté ici. — Dakdada 6 novembre 2014 à 20:05 (UTC)
@Dakdada : c’est une très très mauvaise idée. Si tu essaies ça… n’essaie pas, ce sera mieux.
@JackPotte : tu le fais ? --GaAs 6 novembre 2014 à 20:12 (UTC)
Je l'aurais traité ce soir si mes travaux en Lua n'étaient pas boycottés malgré le mieux qu'ils apporteraient à la situation actuelle. JackPotte ($) 6 novembre 2014 à 20:20 (UTC)
JackPotte : premièrement être accusé de boycotte ne donne pas envie d'aider. Deuxièmement, penses-tu qu'il vaille la peine d'utiliser Module:clé de tri maintenant sachant que Module:clé de tri2 pourrait faire les choses mieux (la clé de tri n'étant pas juste une version sans accents) ? — Dakdada 6 novembre 2014 à 20:58 (UTC)
C'est justement l'argument que j'aurais utilisé pour mettre hors jeu ta formule regex. Mon module avait le mérite de dresser une liste exhaustive des ordres alphabétiques pour chaque langue, ce n'était pas moins bien. JackPotte ($) 6 novembre 2014 à 21:01 (UTC)
Par contre il n'était pas clair que l'utilisation de Module:clé de tri2 engendrerait la suppression de {{clé de tri}} une fois intégré aux modèles catégorisant pourvus d'un code langue. Je viens juste de le comprendre après avoir suivi toutes les discussions à ce propos. JackPotte ($) 6 novembre 2014 à 21:14 (UTC)
Ainsi, je pense que nous pourrons en finir ce mois-ci avec ce problème : Discussion_module:clé_de_tri2#Pr.C3.A9paration_des_cl.C3.A9s_de_tri. JackPotte ($) 6 novembre 2014 à 21:43 (UTC)

Bogue avec les balises references[modifier le wikicode]

Sur Abelardo, on peut voir que le paramètre page du modèle {{R:Antroponimia Aragonesa}} est renseigné et le rendu s’affiche correctement dans la page concernée.
Mais ce n’est pas le cas sur abattage. Je viens juste de rénover le modèle {{R:DicoHayard}} pour intégrer ce paramètre page et le rendu s’affiche seulement lorsque le modèle n’est pas entre les balises <references></references>. Dès qu’il est intégré on dirait que le paramètre page n’est plus pris en compte. Est-ce un problème de cache qui se résoudra tout seul d’ici la fin de la journée (la mise à jour du modèle est récente) ou ça peut venir d’autre chose ? (Et dans ce cas pourquoi deux cas identiques ne sont pas traités de la même manière ?) V!v£ l@ Rosière /Murmurer…/ 7 novembre 2014 à 08:01 (UTC)

fait Corrigé : c'est dans l'appel du modèle dans le texte qu'il faut préciser les paramètres. Il n'est pas nécessaire de les mettre dans <references></references>. — Dakdada 7 novembre 2014 à 09:34 (UTC)
Merci, je corrige le reste. V!v£ l@ Rosière /Murmurer…/ 7 novembre 2014 à 13:40 (UTC)

Problèmes de la catégorisation HotCat[modifier le wikicode]

On avait décidé, il me semble, de placer les catégories sous les sections langues concernées. Cependant on dirait que c’est chose impossible pour le gadget HotCat dans son état actuel [1]. Est-ce que ce problème peut-être géré directement par le gadget où y a-t-il un robot qui s’occupe de trier les catégories après leurs ajouts ? V!v£ l@ Rosière /Murmurer…/ 10 novembre 2014 à 08:54 (UTC)

Je me souviens que Daahbot l'avait fait sur toutes les pages après la prise de décision. Mais comme on en retrouve régulièrement, je me réserve le droit de le faire éventuellement prochainement. Et si cela est fait via les RC, disons au moins 24 h après une édition car en dessous cela gène la patrouille. JackPotte ($) 10 novembre 2014 à 09:18 (UTC)
D’acc. V!v£ l@ Rosière /Murmurer…/ 16 novembre 2014 à 19:26 (UTC)
Daahbot ne l'a pas fait, cf Utilisateur:Daahbot/Historique. C'est d'ailleurs plus dans les compétences de JackBot. — Dakdada 17 novembre 2014 à 09:24 (UTC)

{{kk-déclc}}[modifier le wikicode]

Bonjour suite à cette remarque de Talkavo (d · c · b), est ce que quelqu’un pourrait faire le nécessaire dans {{kk-déclc}} ? J’ai regardé le code mais ça me semble imbitable … Pamputt [Discuter] 16 novembre 2014 à 18:11 (UTC)

Ne pas inclure le modèle dans la catégorie[modifier le wikicode]

Salut. Sous ce titre énigmatique, je voudrais savoir s'il est possible que {{lv-décl-m-s}} et sa page de documentation associée ne soit pas présent dans la catégorie Noms communs en letton de la première déclinaison ? Pour le moment j’ai fait ça qui aboutit au résultat actuel. Pamputt [Discuter] 20 novembre 2014 à 18:19 (UTC)

Tu as le choix entre le "nocat" qui nécessite de modifier la doc, ou le "if namespace" qui restreint tous les modèles. JackPotte ($) 20 novembre 2014 à 18:52 (UTC)
Je l’ai fait au passage, avec le « if:namespace ». — Automatik (discussion) 20 novembre 2014 à 20:17 (UTC)
Big Brother was here. --GaAs 20 novembre 2014 à 20:26 (UTC)

Merci bien. Question subsidiaire, est ce qu’il y a un moyen de ne catégoriser que lorsque le titre de la page correspond au nominatif singulier ? Par exemple, je voudrais que suns soit présent dans Noms communs en letton de la deuxième déclinaison mais pas suni. Il y a un moyen facile de faire ça ? Pamputt [Discuter] 20 novembre 2014 à 21:55 (UTC)

Convertir les modèles en lua ouvre des tas de possibilités. En restant avec du wikicode, la réponse à ta question est probablement négative. --GaAs 20 novembre 2014 à 22:02 (UTC)
Je ne connais rien en lua. Mais si tu me convertis un des modèles du letton en lua, je me charge de faire la conversion pour tout le reste. Pamputt [Discuter] 20 novembre 2014 à 22:17 (UTC)
Merci à Automatik qui a proposé une solution. Cela dit, si quelqu’un me montre comment convertir ces modèles en lua, ma proposition tient toujours. Pamputt [Discuter] 20 novembre 2014 à 22:41 (UTC)
Voir Wiktionnaire:Wikidémie/novembre_2014#Nouveau Modèle:fr-accord-al en lua : enfin prêt ?. Pamputt, je ne veux pas dire que ça va t’apprendre le lua en 5 minutes, mais ça peut te donner des idées. Je veux bien t’aider, mais je ne garantis pas de délai. --GaAs 22 novembre 2014 à 22:38 (UTC)

Connaitre le nom du modèle qui a appelé la fonction lua[modifier le wikicode]

Bonjour. Dans structure d’appel la plus fréquente, on a :

  1. une page qui appelle un modèle,
  2. le modèle qui fait un #invoke pour appeler une fonction lua dans un module,
  3. la fonction lua dans le module qui reçoit un paramètre frame.

Dans la fonction lua, je sais récupérer :

  • les paramètres passés au niveau 1 : frame:getParent().args
  • les paramètres passés au niveau 2 : frame.args
  • le nom de la page au niveau 1 : mw.title.getCurrentTitle().text

Mais je ne trouve pas comment faire pour connaitre le nom du modèle du niveau 2, auriez-vous une idée ?

L’usage que je voudrais en faire est la construction de messages d’erreur les plus précis possibles, sachant qu’une même fonction lua peut potentiellement être appelée par plusieurs modèles, voire le modèle renommé. --GaAs 23 novembre 2014 à 09:29 (UTC)

Passer le nom du modèle en paramètre du #invoke serait une solution. (Je ne crois pas qu'il y a plus simple, mais peut-être que d’autres sauront.) — Automatik (discussion) 23 novembre 2014 à 10:50 (UTC)
Maintenant que j’y pense, il me semble qu’il n’y a pas de solution pour les modèles programmés en wikicode, càd pas de mot magique pour connaitre dans un modèle le nom de l’appelant. Voir par exemple {{fr-conj-intro}}, qui a ce besoin et pour lequel j’avais mis un paramètre mdl= pour ça.
Ça ne prouve pas que ça n’existe pas en lua, mais c’est mauvais signe.
--GaAs 23 novembre 2014 à 12:28 (UTC)

mw.ustring.gsub[modifier le wikicode]

Bonjour. La fonction mw.ustring.gsub en Lua ne semble pas marcher bien. Voyez les exemples dans Discussion module:str#fonction gsub. Le deuxième résultat devrait être AB3EF mais il est maintenant ABC-2EF. Pourquoi ? — TAKASUGI Shinji (d) 23 novembre 2014 à 11:02 (UTC)

Car - est un caractère spécial qu'il faut échapper. — Automatik (discussion) 23 novembre 2014 à 11:15 (UTC)
C’est un quantifieur « non gourmand », qui va récupérer le moins de fois possible le caractère précédant, selon mw:Extension:Scribunto/Lua_reference_manual#Patterns. — Automatik (discussion) 23 novembre 2014 à 11:18 (UTC)
Et voir http://www.lua.org/manual/5.1/manual.html (souvent plus précis que la doc MW) §5.4.1 – Patterns :
« x: (where x is not one of the magic characters ^$()%.[]*+-?) represents the character x itself. »
Donc il faut mettre un % pour le tiret. --GaAs 23 novembre 2014 à 11:26 (UTC)
Merci. Je mettais « \ » pour échapper comme Perl. — TAKASUGI Shinji (d) 23 novembre 2014 à 12:04 (UTC)

Plantage de la barre de recherche & co[modifier le wikicode]

Effectivement, je ne sais pas pour vous, mais moi en tout cas elle ne me fait plus aucunes propositions de mots lorsque je tape dedans. (Windows 7, Firefox 33.1)
EDIT : Pire j’ai tapé « avoir l'air » et ça ne m'a même pas redirigé vers avoir l’air, ça ne me propose que cette page. Je remarque également que ma page JS perso ne marche que partiellement (les boutons d'éditions personnalisés n'apparaissent plus lors de l'édition alors que les liens personnalisé du menu de gauche apparaissent et sont fonctionnels). Pareil le gadget Specialchars ne fonctionnent plus.
EDIT 2 : J’ajoute que sur Wikisource absolument tout ce qui est sus-mentionné marche très bien, donc ça viens bien de chez nous. V!v£ l@ Rosière /Murmurer…/ 26 novembre 2014 à 16:43 (UTC)

Je viens d'essayer de rechercher avoir l'air dans la zone de recherche à gauche, au dessus des commandes de navigation, et j'arrive bien à la page voulue (avec Firefox). Je précise que j'ai cliqué sur Lire. Quand je clique sur Rechercher, j'arrive bien à la page donnée dans le lien ci-dessus, ce qui est logique, puisqu'on ne demande pas de lire une page, mais de rechercher un mot sur le site. Et quand je recherche poissonn, j'arrive bien à une liste de pages proposées logique. Lmaltier (discussion) 26 novembre 2014 à 18:33 (UTC)
Depuis aujourd'hui mon auto-complétion foire complètement (Firefox, Monobook). Avant de cliquer sur "lire" ou "rechercher", j'avais toujours des propositions dans l'ordre alphabétique. De plus, quand je cliquais dessus avec ma molette ça les ouvrait dans un onglet, plus maintenant. J'ai l'impression que les nouvelles suggestions sont classées par ancienneté de création (les DBA ont dû tronquer une table temporaire)... JackPotte ($) 26 novembre 2014 à 18:56 (UTC)
Et MediaWiki:Edittools est en carafe par dessus le marché. JackPotte ($) 26 novembre 2014 à 19:57 (UTC)
L'autocomplétion ne marche pas pour moi non plus, et mon common.js n'est chargé qu'aléatoirement. L'éditeur visuel n'est plus activé, mais MediaWiki:Edittools marche bien. Pourtant, rien qui ne semble venir des scripts du Wiktionnaire [2]. Automatik (discussion) 26 novembre 2014 à 20:57 (UTC)
Pareil, la barre de recherche ne me propose jamais de page à créer lorsqu’une proposition existe. Et je n’ai plus l’éditeur visuel non plus. (Vector, W7, firefox) --Lyokoï (discussion) 26 novembre 2014 à 23:30 (UTC)
fait Corrigé : l’erreur était double ; d’une part l’éditeur visuel a été désactivé inopinément durant la dernière maj MediaWiki (cf. rapport de bug), d’une autre le gadget SousPages reposait sur l’éditeur visuel (il allait chercher dans la configuration de l’éditeur visuel quels espaces de noms acceptaient les sous-pages). Le gadget est donc maintenant indépendant de cela, et l’éditeur visuel devrait revenir d’après un développeur. — Automatik (discussion) 26 novembre 2014 à 23:37 (UTC) NB : si au moment de lire mon message, certains javascripts ne marchent toujours pas pour vous, essayer de purger le cache de son navigateur (CTRL+F5) devrait résoudre le problème.
fait Merci, tout est rentré dans l’ordre. V!v£ l@ Rosière /Murmurer…/ 27 novembre 2014 à 12:35 (UTC)

Choper un Dump du wiktionnaire en moins de 3h...[modifier le wikicode]

Bonjour, cher amis techniques… J’ai commencé à m’intéresser aux dumps du WT afin de remplir une partie de annexe:Rimes en français. Le besoin s’en est fait sentir lorsque j’ai voulu compléter Annexe:Rimes_en_français_en_/az/ et que je me suis aperçu qu’il fallait que je liste tous les mots qui finissais par -oise. J’ai donc utilisé anagrimes quand j’ai compris que beaucoup, beaucoup, BEAUCOUP de gentilés s’y trouvaient… Après trop de d’erreur 504, j'ai cherché à faire tourner cette recherche sur mon propre pc. Et je suis tombé sur AWB qui a l’air cool. Néanmoins, ces requêtes, faites grâce au database scanner, ont besoin d’une base de donnée. Et c’est là que ça coince. Je n’arrive pas à obtenir une BDD dans un temps suffisamment court pour ne pas faire sauter ma connexion et corrompre le fichier. J’essaie de télécharger « frwiktionary-20141102-pages-meta-current.xml.bz2 (305.9 MB) », c’est pas trop lourd pourtant… mais les serveurs sont apoplectiques et c’est impossible de le faire en moins de trois heures… Quelqu’un peut me sauver ? --Lyokoï (discussion) 26 novembre 2014 à 23:20 (UTC)

Oui, car c’est frwiktionary-20141102-pages-articles.xml.bz2 que tu dois prendre, pas le meta contenant tout l’historique de toutes les pages, le premier fichier suffit pour la version actuelle des pages. — Automatik (discussion) 26 novembre 2014 à 23:43 (UTC)
En fait non, ce sont quasiment les mêmes fichiers (le second est simplement un peu moins lourd). Ta connexion est trop lente, il faut changer d’opérateur… Mort de rire Je pourrais essayer de te le mettre sur le cloud (genre avec Dropbox) pour que tu le charges depuis un autre serveur mais je doute que ce soit une question de serveur, je pencherais plus pour la bande passante (à moins que ta connexion ne soit bonne en dehors de ça). — Automatik (discussion) 26 novembre 2014 à 23:44 (UTC)
Ouais… je tape 1,5 Mo en moyenne… ça vient pas de ma connexion… malheureusement. --Lyokoï (discussion) 27 novembre 2014 à 00:14 (UTC)
Quand j’essaie de télécharger le dump, j’obtiens un temps d’attente de 10 minutes environ, après stabilisation. — Automatik (discussion) 27 novembre 2014 à 00:22 (UTC)
Bon, j'ai 45 minutes là. Si je l'ai pas ce soir, je testerai demain matin. Ce doit être une congestion quelque part… --Lyokoï (discussion) 27 novembre 2014 à 00:30 (UTC)
C’est bon, je l'ai. et à première vue, il y a un truc comme 38 000 mots avec oise… soit 30 000 rimant avec /az/ à la louche… yeaaaaaaaaah… Bon, je trierais ça demain. --Lyokoï (discussion) 27 novembre 2014 à 01:11 (UTC)
En fait c’est bien le dump dont je te parlais frwiktionary-20141102-pages-articles.xml.bz2 qu'il faut choisir : il semble à peine plus petit, mais il est beaucoup plus rapide à charger. — Automatik (discussion) 27 novembre 2014 à 10:57 (UTC)
Je confirme. Et avoir la fibre plutôt que l’ADSL permet d’accélérer notablement le chargement de fichiers de ce genre, ce qui explique la différence entre ton chargement précédent et le mien (testé). — Automatik (discussion) 5 janvier 2015 à 19:10 (UTC)
Je peux fournir ce qu'il faut pour reconstruire la base d'anagrimes en local (sqlite ou mysql) pour ceux qui n'ont pas peur d'utiliser SQL. L'avantage par rapport aux dumps et AWB étant bien sûr que la structure du Wiktionnaire est déjà parsée (e.g. séparation par langues, etc.). C'est très rapide en local (prévoir bien 2Gio pour la base).
Exemple : je trouve en français 19428 mots en -oise, dont 9442 sont reconnus comme gentilés (noms ou adjectifs). Du total, seules 1032 ont une prononciation précisée. — Dakdada 27 novembre 2014 à 09:53 (UTC)
Ah ! Ça m’intéresse ! Bon vu que je viens de commencer sur AWB, je vais continuer dessus là tout de suite maintenant, mais je reviendrai vers toi, j’ai besoin de faire des stats qu’AWB peut pas me sortir, et je me désole de pouvoir faire des requête SQL dessus. Sourire --Lyokoï (discussion) 27 novembre 2014 à 11:31 (UTC)
Tu peux télécharger la dernière version ici : [3]. — Dakdada 27 novembre 2014 à 13:43 (UTC)

Taille par défaut des images des galeries[modifier le wikicode]

Bonjour, je souhaiterais faire en sorte que les images fassent 120px par défaut sur un wiki (au lieu de 185px) mais sans qu'elles ne dépassent x120px. Comment faire ?

Voir Aide:Image. JackPotte ($) 28 novembre 2014 à 20:14 (UTC)
Merci, mais ce que je demande c'est comment faire pour que toutes les galeries soient comme ça sans ajouter widths="120px" (CSS ?).
Sur mon Firefox en habillage Monobook, la largeur des images en galerie toujours de 120px (et celle en vignette est toujours de 220px), et la hauteur varie selon le fichier.
Si nous voulions toutes les modifier sur le site il faudrait recueillir un consensus dans une WT:Prise de décision avant de toucher à Mediawiki:Common.css. JackPotte ($) 28 novembre 2014 à 22:55 (UTC)
En fait, JackPotte je crois qu’il y a un malentendu. Je pense que l’IP en parlant d’un wiki ne parle du Wiktionnaire mais plutôt d’un wiki privé. (Hahaha on dirait que cette page devient également populaire extra-muros à l’instar de WT:QM) V!v£ l@ Rosière /Murmurer…/ 28 novembre 2014 à 23:21 (UTC)
Oui c'est ça.